Pivots & Charts

Purdue University
IT Computing Services
Staff Computer Training
www.purdue.edu/itap/itcs/sct
Revised: March 1, 2003
Table of Contents

ABOUT THIS TRAINING .................................................................................................................. 1

TRAINING OBJECTIVES ................................................................................................................. 1

STANDARD CONVENTIONS FOR DOCUMENTATION .................................................................. 2
KEYBOARD CONVENTIONS ........................................................................................................... 2
MOUSE CONVENTIONS .................................................................................................................. 2

WHAT IS BRIQUERY? ...................................................................................................................... 3

BENEFITS OF BRIQUERY ............................................................................................................... 3

BRIQUERY SECTIONS (SECTION PANE) .......................................................................................... 3

BRIQUERY WINDOW FEATURES AND TOOLS ............................................................................. 4

MENU BAR ......................................................................................................................................... 4
REQUEST LINE ................................................................................................................................. 4
LIMIT LINE ....................................................................................................................................... 5
SORT LINE ....................................................................................................................................... 5
TOOLBARS ....................................................................................................................................... 5
CONTENTS PANE ................................................................................................................................ 7
SECTION PANE ................................................................................................................................ 7
SECTION TITLE BAR ....................................................................................................................... 7
CATALOG PANE ................................................................................................................................ 8
STATUS BAR ..................................................................................................................................... 8
OUTLINER ........................................................................................................................................... 9

NOTES ................................................................................................................................................ 10

USING THE PIVOT SECTION .......................................................................................................... 11

➤ APPLYING THE SPOTLIGHTER ....................................................................................................... 11
EXERCISE 1: EMPLOYEES’ SALARIES .......................................................................................... 11
➤ MODIFYING FORMATS IN THE SPOTLIGHTER .......................................................................... 14
➤ COPYING FORMATS IN THE SPOTLIGHTER ............................................................................... 15
➤ REMOVING SPOTLIGHTER FORMATS ....................................................................................... 16
➤ USING “% OF COLUMN” DATA FUNCTION IN A PIVOT REPORT .............................................. 17
EXERCISE 2: % OF COLUMN BY STAFF TYPE ................................................................................ 17
➤ ADDING COLUMN LABELS ........................................................................................................... 19
➤ GENERATING TOTALS AND SUBTOTALS .................................................................................. 20
EXERCISE 3: TOTALS AND SUBTOTALS ..................................................................................... 20
➤ REMOVING TOTALS ..................................................................................................................... 21
➤ GROUPING LABELS IN A PIVOT REPORT .................................................................................... 23
EXERCISE 4: GROUP DEPARTMENTS BY ACADEMIC & ADMINISTRATIVE AREAS .................. 23
➤ UNGROUPING LABELS ................................................................................................................... 24
➤ DUPLICATING A PIVOT REPORT................................................................................................ 25
➤ CLASS EXERCISE ........................................................................................................................ 26

USING THE CHART SECTION ......................................................................................................... 31

➤ CHART TYPE DIFFERENCES ........................................................................................................ 31
➤ CHARTING A PIVOT REPORT ....................................................................................................... 33
➤ INSERTING A CHART ..................................................................................................................... 34
About This Training

This BrioQuery training assists the learner in the use of the BrioQuery software. The training is intended for an intermediate or advanced user with prior experience in using this type of software and relational databases. Prior knowledge of the use of the Microsoft Windows 2000 operating system is required.

Training Objectives

This training will cover techniques used in the Pivot and Chart Sections of BrioQuery and will focus on how to create and edit pivots and charts.

In this training you will learn:

- Basics of the BrioQuery Window
- How to Use the Spotlighter
- How to Use Data Functions
- How to Generate Totals & Subtotals in a Pivot report
- How to Use the Group Function
- How to Create and Edit Charts
- BrioQuery Tips
Standard Conventions for Documentation

- Actions are **bolded** and CAPITALIZED
- Special notes are *italicized*
- Button and menu names are set to 14 point font size and underlined.
- File names, paths or directories are printed in **Courier New**

Keyboard Conventions

- Names of keys that you press during hands-on exercises are in small capital letters, for example, TAB and SHIFT.
- A plus sign (+) between two key names means those keys must be pressed at the same time. For example, “Press ALT+TAB” means to hold down ALT while pressing TAB.
- A comma (,) between two or more key names means that you must press each of the keys consecutively, not together. For example, “Press ALT, T, X” means to press and release each key in sequence. “Press ALT+W, L” means to first press ALT and W together, release them, and then press L.

Mouse Conventions

- Click means to point to an object and then press and release the left mouse button. The word “click” is used for selecting command buttons, option buttons, and check boxes.
- Drag means hold down the mouse button while moving the mouse.
- Double Click means to rapidly press and release the mouse button twice.
- Right Click means to point to an object and then press and release the right mouse button. Clicking the right mouse button opens a shortcut menu that provides easy access to commands associated with the current action.
What is BrioQuery?

BrioQuery is a query and reporting tool for accessing databases from the Windows desktop. It allows the user to access data that is stored on database servers without understanding the complexity of query programming language. BrioQuery allows the user to create a query (or question) of the database. The information is retrieved in a spreadsheet-like format, and various reports can be created from that information. BrioQuery filters large quantities of data to select only what is desired. It also quickly formats data so results can be evaluated and understood.

Benefits of BrioQuery

- User-friendly Tool
- Pre-defined Data Models, Queries, and Reports stored in the repository
- User may create queries
- User may create reports that help answer management decisions with a reasonable response time
- User may focus on information without worrying about file structure
- User may save queries for later use or modifications

BrioQuery Sections (Section Pane)

- **Query** - Specifies the database fields that are to be retrieved and optional limit and sort conditions on the data values. Multiple queries can be created in a single *.bqy file.
- **DataModel** – A visual representation of an actual database.
- **Results** - Displays the data that matches the criteria in a query using a table format.
- **Pivot** - Constructs pivot reports summarizing query result data by various categories.
- **Report** - Formats reports that display and group the query results.
- **Table** - Displays a columnar representation of the data. The table section functions like the Results section in that Pivots and Charts can be based on a table’s dataset.
- **Chart** – Creates a 3-D graphic representation of data results.
- **Executive Information System (EIS)** – Allows users to build and deploy analytic applications. The EIS section is a pushbutton approach to querying a database. It is a document front-end that makes it easy for end-users to access information.
**BrioQuery Window Features and Tools**

There are a number of features and tools included in the BrioQuery screen display which are very useful. These include: the Standard Toolbar, the Request Line, Section Panes, and the Status Bar.

The following graphics show menus, toolbars and lines which appears when BrioQuery is launched. This includes the BrioQuery menu bar, the Standard Toolbar, and the Request Line.

**Menu Bar**
The menu bar shown is from the Query section and will be the menu bar shown at startup. Each section of BrioQuery has its own menu bar. While the File and Edit menus are standard across all sections, other menus will appear depending on which section is active.

Menu Bar

![Menu Bar](image)

**Request Line**
The Request Line is the area where named items (columns) are placed to return data from the database.

Request Line

![Request Line](image)

**Limit Line**
The Limit Line is the area where "limits" or criteria are placed on named items (columns) so that a smaller, more specific, subset of data is returned from the database. To view the Limit Line, **CLICK** on the **Limits** button in the **Section Title Bar**.
Sort Line
The Sort Line is the area where sort conditions on data fields are placed so that the data is returned in a specific order. To view the Sort Line, CLICK on the Sort button in the Section Title Bar.

Toolbars
The Standard Toolbar can be opened using the View menu. Whenever a query is created or opened this toolbar will be displayed. You can choose not to display this toolbar; however it is extremely useful. When you choose not to display the toolbar, it will not reappear when the tool is opened again.

In BrioQuery, typically there are at least three methods for performing most activities: a button on a Toolbar, a menu option, or a drag and drop method. If you choose not to use the Standard Toolbar, you have the option to use various menus to perform the same functions. Features from some of the menus are duplicated in the Standard Toolbar.
The functions available via the buttons in the Standard Toolbar are:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>New Document</td>
</tr>
<tr>
<td></td>
<td>Open BrioQuery Document</td>
</tr>
<tr>
<td></td>
<td>Save BrioQuery Document</td>
</tr>
<tr>
<td></td>
<td>Print</td>
</tr>
<tr>
<td></td>
<td>Print Preview</td>
</tr>
<tr>
<td></td>
<td>Remove</td>
</tr>
<tr>
<td></td>
<td>Show Section/Catalog</td>
</tr>
<tr>
<td></td>
<td>Insert New Section</td>
</tr>
<tr>
<td></td>
<td>Properties</td>
</tr>
<tr>
<td></td>
<td>Limit</td>
</tr>
<tr>
<td></td>
<td>Sort Ascending</td>
</tr>
<tr>
<td></td>
<td>Sort Descending</td>
</tr>
<tr>
<td></td>
<td>Apply Sum</td>
</tr>
<tr>
<td></td>
<td>Group Labels</td>
</tr>
<tr>
<td></td>
<td>Process</td>
</tr>
<tr>
<td></td>
<td>Connection Manager</td>
</tr>
<tr>
<td></td>
<td>Back</td>
</tr>
<tr>
<td></td>
<td>Forward</td>
</tr>
<tr>
<td></td>
<td>EIS Home</td>
</tr>
<tr>
<td></td>
<td>Help</td>
</tr>
</tbody>
</table>

The **Formatting** toolbar is available in the **View** Menu. This toolbar will allow you to customize your reports to highlight important information and format how it looks.

The **Formatting** toolbar is a graphical representation of the functions supported by the various options in the **Format** menu. The **Format** menu is useful for making changes in all the sections: the **Results** section, the **Pivot** section, the **Table** section and the **Report** section.

The **Section** toolbar is only available in specific sections and provides commands to use in those sections.
Contents Pane
The Contents Pane is the lower right area of the window. The Contents Pane provides a view of the section you are using. It will show a Data Model, a Query, a Report, a Pivot or a Chart.

Section Pane
The Section Pane is located to the left of the Contents Pane. The Section Pane allows quick access to every section of the BrioQuery window: the Query section, the Results section, the Pivot section, the Chart section, and the Report section. There can be multiple Pivots, Charts and/or Reports, and therefore multiple sections. Pivot, Report and Chart do not automatically appear in the Section Pane. To create them, you must insert them from the Insert menu. To view the different sections, CLICK on each section and view it in the Contents Pane or you can use the back and forward arrows in the Section Title bar.

Section Title Bar
The Section Title bar is a horizontal banner that runs across the top of each section. It displays the document sections that you are currently working with and includes buttons to navigate forward and back between sections. Clicking on a section will enable different buttons specific to that section. The Pivot section title bar consists of the following single-click buttons: Sort and Outliner. Each of these buttons will toggle the respective area on and off.

The Sort button toggles the Sort bar on/off, which allows you to rank data.

The Outliner button toggles the Outliner on/off. This is the area where you can insert facts and labels to create a pivot report.
Catalog Pane
The Catalog Pane is also located to the left of the Contents Pane. The Catalog Pane contains the data and objects that are used to build Pivot Reports, Charts, Tables and Reports. The Catalog Pane changes depending on the section you are working in. To use the Catalog Pane, drag an object from the Catalog Pane to the Contents Pane or to the Outliner.

Status Bar
At the very bottom of the BrioQuery window is the Status Bar. This feature gives you information about the number of rows returned by a query, the number of columns selected for the query, a graphic to show whether the database connection is active, and an information area which provides help information when you move the cursor to different areas of the window. The status bar will provide status statements during connection and processing.
**Outliner**

The Outliner in the Pivot section consists of the **Dimension Labels** and the **Facts**. When data is placed in the top and side panels of the Outliner, it will create the top and side labels of the Pivot report. The bottom right panel holds the report facts. Dimensional labels line the top and left sides of a Pivot report. Dimensions break data facts into logical categories. Each dimension item has an interactive handle. You can work with individual labels, or select the handle to work with the entire dimension item. The Facts pane allows you to define measurable values or data that can be aggregated.
DISCLAIMER:

• All of the results in this manual are based on using the Training instance of the Employee Appointment data model.

• You will need to create a training OCE to access the training instance.

• If you have problems, contact the WAI Business Analyst at 49-49943.
Using the Pivot Section

Pivot reports resemble spreadsheets and are used to analyze data. The Pivot section allows you to quickly perform sophisticated computations, as well as the capability of drilling down to review how data is summarized. You can also pivot the data to change the way it is viewed. Pivot reports allow the user to add, move, rename, and group dimensions to create customized views of the data. All of the exercises in this manual will be done using a Training datamodel, with the host dssqa. For detailed instructions on creating a training OCE, see the Open Catalog Extensions section in the Brio Query 6 Training Guide.

Applying the Spotlighter

Once you have created the pivot report, you can use the Spotlighter to emphasize sections of the pivot by applying formatting such as styles or colors. Formats are applied by setting conditions.

Exercise 1: Employees’ salaries

Apply formatting using the Spotlighter. Apply gray shading to all employees making less than or equal to $40,000.

To apply the spotlighter:

1. OPEN the file, spotlighter.bqy and log on, if necessary.
2. SELECT the Pivot Section, if necessary.
3. CLICK in the Full Time Annual Rate column to SELECT it.
4. From the Format menu, SELECT Spotlighter...
5. **CLICK** on the drop down arrow next to **Operator** and **SELECT** a comparison operator from the list. **SELECT** \( \leq \) less than or equal to.

6. **CLICK** in the **Value** box and enter a comparison value. **TYPE** in 40000.

7. Add formatting. **CLICK** the **Fill Color** button and **SELECT** **Gray**. (You can also select the **Text Color** button to change the color of text.)

8. **CLICK** to apply the formatting in the **Spotlighter** to the selected column.

9. **CLOSE** the **Spotlighter** dialog box, and deselect the column to view the **Spotlighter** features.

The pivot should look like this:
<table>
<thead>
<tr>
<th>ID</th>
<th>Role</th>
<th>Last Name</th>
<th>First Name</th>
<th>Annual Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>0571</td>
<td>Clinical</td>
<td>LANDAU</td>
<td>MARTIN</td>
<td>$16,720</td>
</tr>
<tr>
<td>0575</td>
<td>Clinical</td>
<td>POND</td>
<td>LAWES</td>
<td>$23,620</td>
</tr>
<tr>
<td>0589</td>
<td>Service</td>
<td>PIGEY</td>
<td>MILES</td>
<td>$15,420</td>
</tr>
<tr>
<td>0595</td>
<td>Faculty</td>
<td>CURTIS</td>
<td>TONY</td>
<td>$16,500</td>
</tr>
<tr>
<td>0600</td>
<td>Grad Student</td>
<td>CLAYTON</td>
<td>ALI</td>
<td>$11,190</td>
</tr>
<tr>
<td>0601</td>
<td>Grad Student</td>
<td>KAREV</td>
<td>CHRISTOPHER</td>
<td>$10,700</td>
</tr>
<tr>
<td>0602</td>
<td>Service</td>
<td>CAIN</td>
<td>MICHAEL</td>
<td>$20,000</td>
</tr>
<tr>
<td>0604</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0605</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0606</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0607</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0608</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0609</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0610</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0611</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0612</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0613</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0614</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0615</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0616</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0617</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0618</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0619</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
<tr>
<td>0620</td>
<td>Admin Professional</td>
<td>LOWE</td>
<td>JACOB</td>
<td>$21,480</td>
</tr>
</tbody>
</table>
Modifying Formats in the Spotlighter

After applying a format using the Spotlighter, you may need to modify the value or format.

**TO MODIFY THE SPOTLIGHTER FORMATS:**

1. **SELECT** the column that contains the Spotlighter formats. **SELECT** the Full Time Annual Rate column.

2. From the **Format** menu, **SELECT** Spotlighter....

3. **DOUBLE CLICK** the Spotlighter value, <=40000, in the **Format Editor** box.

4. Make any changes to the condition or format. **CHANGE** the **Value** to 50000 and **BOLD** the value.

5. **CLICK** to reapply the modified format in the Spotlighter.

6. **CLOSE** the Spotlighter dialog box, and deselect the column to view the changes.

*The pivot should look like this:*
Copying Formats in the Spotlighter

Once you have applied formats using the Spotlighter, you can copy the formats to other columns.

**To Copy Spotlighter Formats:**

1. Before copying Spotlighter formats, **ADD** another Full Time Annual Rate field to the Facts section in the Outliner.
2. **RESIZE** the column to view the entire column heading.
3. **SELECT** the column that contains the Spotlighter formats. **SELECT** the Full Time Annual Rate column.
4. From the Format menu, **SELECT** Spotlighter…
5. **CLICK** the Capture button.
6. **SELECT** the column you want to apply the formats to. **SELECT** the Full Time Annual Rate2 column, and **CLICK** the Apply button.
7. **CLOSE** the Spotlighter dialog box, and deselect the column to view the changes.
Removing Spotlighter Formats

Once you have applied formats using the Spotlighter, you can delete the formats if they are no longer needed.

**TO REMOVE SPOTLIGHTER FORMATS:**

1. SELECT the Full Time Annual Rate2 column.
2. SELECT Spotlighter... from the Format menu.
3. SELECT the value, <=50000, in the Format Editor box.
4. PRESS the Delete key.
5. CLOSE the Spotlighter dialog box, and deselect the column to view the changes.
6. CLOSE the query.
Using “% of Column” Data Function in a Pivot Report

The % of Column function calculates the value of the specified measure as a percentage of the total for the column.

Exercise 2: % of Column by Staff Type

Calculate the % of column by Staff Type based on Full Time Annual Rate. Sort Staff Type by percent of Total in descending order.

To use the % of Column data function:

1. OPEN the file, % of column.bqy, and log on, if necessary.
2. ADD another Full Time Annual Rate field to the Facts section in the Outliner.
3. CHANGE the label by DOUBLE CLICKING on the 2nd Full Time Annual Rate column and TYPE “Percent of Total” in the Set Label Item dialog box.
4. CLICK OK.
5. SELECT the Percent of Total column.
6. RIGHT CLICK on the Percent of Total column, SELECT Data Function and CLICK on % of Column. This can also be done by selecting Data Function from the Pivot menu.
7. ENABLE the Sort Line by CLICKING on the Sort button, if necessary.
8. SORT Staff Type by Percent of Total using Sum in descending order.
The pivot should look like this:
Adding Column Labels

Once you have created the Pivot report, you can add labels to each of the columns.

**TO ADD COLUMN LABELS:**

1. **SELECT** the Pivot Section, if necessary.

2. From the **Format** menu, **SELECT Corner Labels** and **SELECT Both**.
   (Tip: You can also **RIGHT CLICK**, **SELECT Corner Labels** and **SELECT Both**.)

The final pivot should look like this:

```
<table>
<thead>
<tr>
<th>Staff Type</th>
<th>Full Time Annual Rate</th>
<th>Percent of Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Faculty</td>
<td>1134959</td>
<td>51%</td>
</tr>
<tr>
<td>AdminProfessional</td>
<td>751405</td>
<td>34%</td>
</tr>
<tr>
<td>Service</td>
<td>193372</td>
<td>5%</td>
</tr>
<tr>
<td>Clerical</td>
<td>136091</td>
<td>6%</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td><strong>2205727</strong></td>
<td><strong>100%</strong></td>
</tr>
</tbody>
</table>
```

3. **CLOSE** the query.
Once you have created the pivot report, you can add totals to each column of data. BrioQuery offers a feature that allows you to easily obtain totals on any column that has a tab at the bottom or on the right side of the column. To generate a total for a column, select the tab of the column to the right of the column you wish to total on.

Exercise 3: Totals and Subtotals
Add totals to the Pivot Report. Total FTE by Staff Type and create a separate total for FTE by Department Number.

To generate totals:

You can generate a total for a column by CLICKING on the tab of the column and SELECTING the ∑ button from the Standard toolbar.

1. OPEN the file, Totals.bqy and log on, if necessary.
2. In the Pivot report, RIGHT CLICK, SELECT Corner Labels and SELECT Both.
3. CLICK on the tab beneath the Staff Type column, and SELECT the Sum or Grand Total button on the Standard toolbar. Note the total generated. This results in a total Fte for each department number.
4. CLICK on the tab beneath the Name Last column, and SELECT the Sum or Grand Total button on the Standard toolbar. Note the total generated. This results in a total Fte for each Staff Type.
5. SORT the Pivot by Dept by FTE using Sum in descending order.
6. USE ALT + CLICK to SELECT the Total rows in the Staff Type column and BOLD them. Check to be sure the Pivot matches the Pivot report on the next page.
The pivot should look like this:

![Pivot Table Example](image)

### Removing Totals

Once you have generated totals using the Grand Total button, you can remove the totals if they are no longer needed.

**TO REMOVE A TOTAL:**

1. SELECT the word "Total" in the Last Name column, and CLICK the Remove button on the Standard toolbar. (Tip: You can also PRESS the Delete Key on your keyboard to remove the total.)
The updated pivot should look like this:

2. **CLOSE** the query.
Grouping Labels in a Pivot Report

Once you have created the pivot report, you can group labels using the Group feature. Grouping labels displays data in an aggregated format with a new summary category.

Exercise 4: Group Departments by Academic & Administrative Areas

Group the BA School fields to aggregate this category into two groups, Academic and Administrative.

To Group Labels:

1. OPEN the file, Grouping.bqy and log on, if necessary.

2. SELECT the Pivot Section, if necessary.

3. SELECT the individual labels to be grouped: AG, CFS, ED, ENGR, LA, MGMT, PHAR, SCI, TECH, and VET MED. USE CTRL + CLICK to SELECT multiple labels.

4. CLICK the Group Items button on the Standard toolbar. (It's the paper clip button.)

5. The selected labels are combined. The resulting label is displayed with an asterisk (*) to indicate a grouping.

6. RENAME the grouped column by DOUBLE CLICKING on the label. TYPE “Academic” in the Set Label Item dialog box to reflect the new column values.

7. CLICK OK.

8. GROUP the remaining labels by repeating the steps above. Label them as “Administrative.” (Tip: Another way to group labels is to USE CTRL + CLICK to SELECT the labels, while you still have the CTRL key PRESSED, also PRESS the G key.)
The pivot should look like this:

➢ Ungrouping Labels

If you no longer need the labels grouped, you can use the Ungroup feature.

**TO UNGROUP LABELS:**

1. **SELECT** the grouped label, “Academic”.

2. **CLICK** the Group Items button on the Standard toolbar. *(It’s the paper clip button.)*

3. The grouped labels are returned to their original configuration.

**Note:** A drawback of grouping is that you must be aware of which fields are included in the group.
Duplicating a Pivot Report

In BrioQuery, you can create multiple reports with the same data. If you would like to create a new pivot report to display the data slightly different, but you don’t want to start from scratch, follow the steps below to duplicate the pivot report.

TO DUPLICATE A PIVOT REPORT:

1. CLICK the Pivot section, if necessary.
2. From the Edit menu, SELECT Duplicate Section.
3. You will notice a new section in the Section Pane named Pivot2. This is a duplicate of Pivot.
4. You can make changes and RENAME the Pivot report by DOUBLE CLICKING on Pivot and TYPING “Academic & Administrative” in the Section Label dialog box.
5. CLICK OK.

The pivot should look like this:
6. CLOSE the query.

➢ Class Exercise

Create three pivot reports.

**PIVOT REPORT 1**

The first pivot report should contain the Employees’ names, and full time annual rates. Use the Spotlighter to emphasize the employees with a full time annual rate greater than $50,000.

1. OPEN the file, pivotexer.bqy, log on and PROCESS the query, if necessary.
2. SELECT the Insert menu and SELECT New Pivot.
3. ADD Name Last and Name First from to the Side Labels section in the Outliner.
4. ADD Full Time Annual Rate to the Facts section in the Outliner.
5. RESIZE the columns to make the text in each column viewable.
6. SELECT the Full Time Annual Rate column in the Pivot.
7. OPEN the Spotlighter.
8. SPOTLIGHT employees with a “Full Time Annual Rate” greater than $50,000 by APPLYING Red and Bold formatting to the values and SHADING the cells in Gray.
9. DESELECT the Full Time Annual Rate column to view the formatting changes.
10. RENAME the Pivot section to “Full Time Annual Rate”.

The pivot should look like this:

![Pivot Table Image]

17. **CLOSE** the query.

**Pivot Report 2**

The second pivot report will also contain Employees’ names and full time annual rates, as well as department titles. You will need to total full time annual rates by department title and figure a percentage of the total by staff type for each department. The query has a limit set on specific department numbers.

1. **OPEN** the file, pivotexer2.bqy, log on and **PROCESS** the query, if necessary.
2. **SELECT** the Insert menu and **SELECT New Pivot**.
3. **ADD** Dept Title, Staff Type and Name Last to the Side Labels section in the Outliner.
4. **ADD** Full Time Annual Rate to the Facts section in the Outliner.
5. **RESIZE** the columns to make the text in each column viewable.
6. **CREATE** a total for each department. (Hint: Click on the Staff Type column and click the Grand Total button.)
7. **CREATE** a grand total to sum all departments.
8. **ADD** another Full Time Annual Rate field to the **Facts** section in the **Outliner**.

9. **RESIZE** the 2nd Full Time Annual Rate column to make all the text viewable.

10. **USE** the **Data Functions** to apply the % of Column function to the 2nd Full Time Annual Rate column.

11. **USE** **ALT+CLICK** to **SELECT** the Total rows in the **Staff Type** column. **CHANGE** the font size to **12** and **BOLD** the font.

12. **RENAMe** the Full Time Annual Rate2 column to “Percent of FTAR”.

13. **RENAMe** the **Pivot** section to “% of Full Time Annual Rate”.

The pivot should look like this:

![Pivot Table Image]

14. **CLOSE** the query.

**Pivot Report 3**

The third pivot report contains staff types, employees’ names and department numbers. Group the staff type to indicate whether the staff are paid on a biweekly or a monthly basis.

1. **OPEN** the file, pivotexer3.bqy, log on and **PROCESS** the query, if necessary.
2. **SELECT** the *Insert* menu and **SELECT** New Pivot

3. **ADD** Staff Type, Staff Type2, Name Last, Name First, and Dept to the Side Labels section in the Outliner.

4. **RESIZE** the columns to make the text in each column viewable.

5. In the first Staff Type column, **SELECT** “Admin/Professional”, “Faculty”, “Fellowship/Stipend” and “Grad Student”. (*To select multiple staff types, use CTRL + CLICK.*)

6. **CLICK** the Group Items button.

7. **RENAME** the grouped section to “Monthly Paid”.

8. In the Staff Type column, **SELECT** “Clerical”, “Service”, and “Undergrad Student”. (*To select multiple staff types, use CTRL + CLICK.*)

9. **CLICK** the Group Items button.

10. **RENAME** the grouped section to “Biweekly Paid”.

11. **CHANGE** the background color of the entire Pivot to light yellow. (*Hint: Use CTRL + A to select the entire Pivot, and use the Fill Color button on the Formatting toolbar.*)

12. **RENAME** the Pivot section to “Staff Payroll Type”.

*The pivot should look like this:*

![Pivot Table Image]

15. **CLOSE** the query.
Using the Chart Section

Charts are graphical representations of data. There are 11 types of charts in BrioQuery. Each may be viewed in a two-dimensional view or a three-dimensional view. The Chart section allows you to add, stack and cluster data in chart objects. A chart can be added to the Report section to complement data values.

➢ Chart Type Differences

The table below illustrates where to place values and labels in the Outliner based on the chart type. The chart type that you select will depend on how you want to view the data.

Type A charts: Values default to Y panel

<table>
<thead>
<tr>
<th>Chart Type</th>
<th>X panel</th>
<th>Y panel</th>
<th>Z panel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Bar</td>
<td>labels</td>
<td>values</td>
<td>labels</td>
</tr>
<tr>
<td>Horizontal Bar</td>
<td>labels</td>
<td>values</td>
<td>labels</td>
</tr>
<tr>
<td>Area</td>
<td>labels</td>
<td>values</td>
<td>labels</td>
</tr>
<tr>
<td>Stacked numeric categories</td>
<td>labels</td>
<td>values</td>
<td>labels/values</td>
</tr>
</tbody>
</table>

Type B charts: Values default to Z panel

<table>
<thead>
<tr>
<th>Chart Type</th>
<th>X panel</th>
<th>Y panel</th>
<th>Z panel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Stacked Bar</td>
<td>labels</td>
<td>labels</td>
<td>values</td>
</tr>
<tr>
<td>Horizontal Stacked Bar</td>
<td>labels</td>
<td>labels</td>
<td>values</td>
</tr>
<tr>
<td>Stacked Area</td>
<td>labels</td>
<td>labels</td>
<td>values</td>
</tr>
</tbody>
</table>

Type C charts: Values possible in either Y or Z panels (defaults to position of previously selected chart type)

<table>
<thead>
<tr>
<th>Chart Type</th>
<th>X panel</th>
<th>Y panel</th>
<th>Z panel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cluster Bar</td>
<td>labels</td>
<td>values/labels</td>
<td>values/labels</td>
</tr>
<tr>
<td>Line</td>
<td>label</td>
<td>values/labels</td>
<td>values/labels</td>
</tr>
<tr>
<td>Bar-line</td>
<td>label</td>
<td>label for 2-values</td>
<td>2-values or labels</td>
</tr>
</tbody>
</table>

Miscellaneous Charts

<table>
<thead>
<tr>
<th>Chart Type</th>
<th>X panel</th>
<th>Y panel</th>
<th>Z panel</th>
</tr>
</thead>
</table>

BrioQuery Level II – Pivots & Charts

Page 31
| Pie | N/A | N/A | N/A |
Charting a Pivot Report

Once you have created a Pivot report, you can automatically generate a chart from the Pivot report, by using the “Chart this Pivot” feature. However, if you change the Pivot report, all items in the chart will not automatically be updated. If you want to use a chart in a report, you should Insert a “New Chart” so that the chart in your report will reflect any changes made to your data. The “New Chart” is automatically updated with changes to the data, whereas the “Chart this Pivot” feature does not automatically update all changes that are applied to the Pivot.

TO CHART A PIVOT REPORT:

1. OPEN the file, pivotchart.bqy, and log on, if necessary. The Brio query file contains a Pivot report.

2. SELECT the Pivot section, if necessary.

3. From the Insert menu, SELECT Chart This Pivot.

4. The chart will look like this. See screen shot on next page.
   To change the chart options, SELECT Properties from the Chart menu.
   (This will enable you to change the chart title, axis labels, etc.)
5. CHANGE the Chart Title to “FTE by Staff Type”. (Hint: If you are not in the Chart properties dialog box, you can Double Click the Chart title to change it.)

6. CLICK OK.

7. To change the chart type, SELECT the drop down arrow on the Chart button on the Formatting toolbar and SELECT the chart type, i.e. Horizontal Bar.
In addition to charting a Pivot report, you can also build your own charts. When you insert a chart, the chart will automatically update after a change has been made to the pivot report.

**TO INSERT A CHART:**

1. From the **Insert** menu, **SELECT** New Chart.

2. **DRAG** the **Head Count Dept** field to the **Y-Facts** section in the **Outliner**.

3. **DRAG** the **Staff Type** field to the **X-Categories** section in the **Outliner**.

4. From the **Chart Type** pull down list on the **Formatting** toolbar, **SELECT** Line.
5. The chart automatically appears as 3-dimensional. To change it to 2-dimensional, **RIGHT CLICK** on the chart and **SELECT Properties**.

6. On the **General** tab, **UNCHECK 3-D objects**.
7. **CLICK OK.**

   *The 2-D chart should look like this:*

![Chart Image]

8. **CLOSE** the query.

---

**Adding a Target Value to a Chart using a Computed Item**

You can create a computed item in a chart to add a target value. To do this, you must create a bar-line chart. In this example, we will add a line on the chart to reflect the Target Average Full Time Annual Rate of $50,000.

---

**TO CREATE A COMPUTED ITEM IN A CHART:**

1. **OPEN** `Computed item.bqy`, and log on, if necessary. The Brio query file contains a chart.
2. **CLICK** on the **Chart** section, if necessary.
3. **USE** the **Chart Type** button on the **Formatting** toolbar to **CHANGE** the chart type to **Bar-Line**.
4. From the **Chart** menu, **SELECT** **Add Computed Item**. *(Tip: You can also **RIGHT CLICK** and **SELECT** **Add Computed Item.)*
5. In the **Name** box, **TYPE** “Target Average FTAR”.

6. In the **Definition** box, **TYPE** 50000 and **CLICK OK**. A line should appear on the 50,000 gridline.

7. **RIGHT CLICK** on the chart and **SELECT Properties**.

8. On the **General** tab, **UNCHECK 3-D objects** to change the chart to two-dimensional.

9. **CLICK OK**.

10. If the values on each side of the chart do not match, **RIGHT CLICK** on the values on the right side and **SELECT Properties**. **CLICK** on the **Values Axis** tab and under the **Right Axis Scale**, **TYPE** in the intervals that you used in the **Left Axis Scale**. Be sure to uncheck the **Auto** check box. (*See the chart on the next page.*)
The chart should look like this:

11. CLOSE the query.

Pulling out a Slice of a Pie Chart

You can move individual pieces of a pie chart to emphasize certain data elements.

To pull out a piece of a pie chart:

1. OPEN Pivotchart2.bqy, and log on, if necessary.
2. From the Insert menu, SELECT New Chart.
3. ADD Staff Type to the X-Categories in the Outliner.
4. ADD FTE to the Y-Facts in the Outliner.
5. From the Chart Type pull down list on the Formatting toolbar, SELECT Pie.
6. **SELECT** the piece of pie labeled “Faculty”, and **RIGHT CLICK** on it.

7. **SELECT** Pull Out Slice from the shortcut menu.

*The chart should look like this:*

---

**Adding Data Labels to Chart Elements**

You can add data labels to a chart. When data labels are added, the labels are added to all categories in the chart. To add an individual label, select the entire chart area, right click and select “Insert Text” from the shortcut menu.

**TO ADD DATA LABELS TO A CHART:**
1. **SELECT** one piece of the pie in the Chart section. **SELECT** Clerical.

2. **RIGHT CLICK** and **SELECT** Show Pie Percentages from the shortcut menu. *(You can also select Show Pie Values depending on the data in the chart).*

*The chart should look like this:*

![Pie Chart Example](chart.png)

5. **CLOSE** the query.

### Rotating A Chart

You can rotate a chart in the Contents pane to alter the perspective and the elevation of a chart.

**To rotate the angle of vision or change the elevation of a bar, line or area chart:**

1. **OPEN** Chart.bqy, and log on, if necessary.

2. **SELECT** the Chart section titled Bar Chart, if necessary.

3. **SELECT** the plot area of the chart (the gray section) and **FLOAT** over the top right corner of the plot area. *The cursor will change to a rotate symbol indicating that you can rotate the chart.*
4. Click and drag the symbol to rotate the chart. When you release the mouse button, the chart will be redrawn. If the chart will not rotate further in a particular direction, the chart has reached its farthest possible rotation in that direction.

The chart should look like this:

➢ Rotating A Pie Chart

You can rotate a pie chart in the Contents pane to alter the perspective and the elevation of a chart.

To rotate the perspective angle or elevation of a pie chart:

1. Select the Chart section titled Pie Chart.

2. Right click in the white area of the chart and select Rotate. The rotate icon will appear on the chart.

3. Click on the Rotate icon and drag upward to change the perspective and elevation of the pie chart.
The chart should look something like this:

4. **RIGHT CLICK** in the chart and **SELECT Rotate** again to disable the rotate feature. *The rotate icon will disappear from the chart.*

---

**Adding Lines to Pie Chart Labels**

You can add pointer lines between individual pie slices and associated labels.

**TO ADD A POINTER TO A SELECTED SLICE:**

1. **CLICK** the pie slice to which you want to add a pointer. *You can use CTRL + CLICK to select all the pieces at once.*
2. **RIGHT CLICK** on the pie slice and **SELECT Line to Label**.
3. **MOVE** the labels so the pointer lines are more visible.
The chart should look like this:

Changing the Color or Pattern of a Chart Category

You can change the color of a chart category (bar on a chart, pie slice, etc.).

**To change the color or pattern of a chart element:**

1. **CLICK** the chart element of which you want to change the color. **SELECT** the Faculty pie slice.

2. **RIGHT CLICK** on the pie slice and **SELECT** Properties. (*You can also double click on the chart element in the legend to bring up this Properties dialog box.*)

3. **SELECT** Foreground and **SELECT** a new color, i.e., fuchsia from the drop down list.

4. You can also select patterns for the chart elements. **SELECT** Custom, and **SELECT** Vertical for the Fill Pattern.

5. **CLICK** OK.
The chart should look like this:

![Pie Chart Image]

6. **CLOSE** the query.
Class Exercise

Create two charts.

Chart 1
Create a pivot report and chart the pivot. The chart will depict head count by staff type. Change the chart type to a pie chart. Add percentages and label pointers to the chart. Change the chart title and change the color of chart elements.

1. OPEN the file, Chartexer.bqy, log on and PROCESS the query, if necessary.
2. SELECT the Insert menu and SELECT New Pivot.
3. ADD Staff Type to the Side Labels section in the Outliner.
4. ADD Head Count Dept to the Facts section in the Outliner.
5. RESIZE the columns to make all the text viewable.
6. CLICK the Insert menu and SELECT Chart this Pivot.
7. CHANGE the chart type to a Pie chart.
8. ADD percentages to the pie slices.
9. PULL out the Grad Student slice of pie.
10. ADD pointers (or lines) to all the pie slices.
11. MOVE the labels so the pointers are visible.
12. CHANGE the chart title to “Head Count by Staff Type”. DELETE the subtitle, if necessary.
13. MOVE the title up so that all the labels are visible.
14. MOVE the legend down to the lower right corner.
15. CHANGE the color yellow to fuchsia.
The chart should look like this:

16. CLOSE the query.

**CHART 2**

Insert a new chart. Add a target value to the chart using a computed item. Limits have been placed on specific department numbers. This chart will depict the years of service of staff by department.

1. OPEN the file, Chartexer2.bqd, log on and PROCESS the query, if necessary.
2. SELECT the Insert menu and SELECT New Chart.
3. ADD Yrs Service to the Y-Facts section in the Outliner.
4. ADD Dept to the X-Categories section in the Outliner.
5. CHANGE the chart type to Bar-Line.
6. CREATE a Computed Item labeled “Target Average Years of Service” and define the target years of service as “25”. A line will appear on the chart at the 25 mark.
7. CHANGE the chart Title to “Target Avg Years of Service”.
8. MOVE the Legend to the bottom right corner so the entire chart is visible.
9. CHANGE the chart to two-dimensional.
The chart should look like this:

10. **CLOSE** the query.
## Limit Table

<table>
<thead>
<tr>
<th>Limit Type</th>
<th>Operation Performed to Select Data</th>
<th>Data on which this comparison is valid</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal =</td>
<td>Only data where the requested item(s) is equal to the specified value(s) will be retrieved.</td>
<td>text, numbers, dates</td>
</tr>
<tr>
<td>Not Equal &lt;&gt;</td>
<td>Only data where the requested item(s) is NOT equal to the specified value(s) will be retrieved.</td>
<td>text, numbers, dates</td>
</tr>
<tr>
<td>Less Than &lt;</td>
<td>Only data where the requested item(s) is less than the specified value(s) will be retrieved.</td>
<td>text, numbers, dates</td>
</tr>
<tr>
<td>Less or Equal &lt;=</td>
<td>Only data where the requested item(s) is less than or equal to the specified value(s) will be retrieved.</td>
<td>text, numbers, dates</td>
</tr>
<tr>
<td>Greater Than &gt;</td>
<td>Only data where the requested item(s) is greater than the specified value(s) will be retrieved.</td>
<td>text, numbers, dates</td>
</tr>
<tr>
<td>Greater or Equal &gt;=</td>
<td>Only data where the requested item(s) is greater than or equal to the specified value(s) will be retrieved.</td>
<td>text, numbers, dates</td>
</tr>
<tr>
<td>Begins With</td>
<td>Only data where the requested item(s) begin with the specified value(s) will be retrieved.</td>
<td>text</td>
</tr>
<tr>
<td>Contains</td>
<td>Only data where the specified value(s) is somewhere in the requested item(s) will be retrieved.</td>
<td>text</td>
</tr>
<tr>
<td>Ends width</td>
<td>Only data where the requested item(s) ends with the specified value(s) will be retrieved</td>
<td>text</td>
</tr>
<tr>
<td>Limit Type</td>
<td>Operation Performed to Select Data</td>
<td>Data on which this comparison is valid</td>
</tr>
<tr>
<td>------------</td>
<td>------------------------------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>Like</td>
<td>Similar to contains; this matches the SQL LIKE command and requires that you use wild card characters to specify where arbitrary characters can be inserted; for most SQL databases such as Oracle, the wild card characters are <code>%</code> (any additional characters to the end of the string) and <code>_</code> (any single character) when entering the specified value. Additional wild card characters may be available and the wild card characters may vary for different databases. In addition, special characters may need to be entered in a specific fashion. e.g. Job_title like ‘T%’ would retrieve records for jobs like Testing, Typist, Truckdriver, etc. e.g. Part_number like ‘F_ABC%’ would retrieve items with part number F1ABC999 and FKABCn3646-S.</td>
<td>text</td>
</tr>
<tr>
<td>Between</td>
<td>Only data where the requested item(s) is between the specified value(s) will be retrieved. Note that data retrieved can also be equal to the specified beginning and ending values.</td>
<td>numbers, text, dates</td>
</tr>
<tr>
<td>Is Null</td>
<td>Only data where the requested item(s) has not been set will be retrieved. Blank strings (i.e. spaces) and zero ARE NOT null values. Only items that have not been set to any value are considered to be null. In DSS, no text is set to Null; numbers or dates are set to Null when no value has been collected. For instance SAT score would be Null if the student had not taken the test.</td>
<td>text, numbers, dates</td>
</tr>
</tbody>
</table>
## Standard Data Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Section Used in:</th>
<th>Operation</th>
<th>SQL Function Generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Query</td>
<td>Returns unaggregated values as stored in the database. This is the default in Query.</td>
<td></td>
</tr>
<tr>
<td>Sum</td>
<td>All</td>
<td>Calculates the sum of the column in each group (numerical data only)</td>
<td>SUM(column definition)</td>
</tr>
<tr>
<td>Average</td>
<td>All</td>
<td>Calculates the average of the column for each group (numerical data only)</td>
<td>AVERAGE(column definition)</td>
</tr>
<tr>
<td>Non-Null Average</td>
<td>Pivot Chart Report</td>
<td>Returns average of underlying values; null values excluded.</td>
<td></td>
</tr>
<tr>
<td>Minimum</td>
<td>All</td>
<td>Returns the smallest entry in each group (numerical data only). You must set the datatype to include text and dates.</td>
<td>MIN(column definition)</td>
</tr>
<tr>
<td>Maximum</td>
<td>All</td>
<td>Returns the largest entry in each group (numerical data only). You must set the datatype to include text and dates.</td>
<td>MAX(column definition)</td>
</tr>
<tr>
<td>Count</td>
<td>All</td>
<td>Counts the number of appearances in each group of each unique value.</td>
<td>Count(column definition)</td>
</tr>
<tr>
<td>Count Distinct</td>
<td>Query</td>
<td>Same as Count but excludes identical rows</td>
<td>COUNT(column definition)</td>
</tr>
<tr>
<td>Null Count</td>
<td>Pivot Chart Report</td>
<td>Returns number of nulls among underlying values.</td>
<td></td>
</tr>
<tr>
<td>Non-Null Count</td>
<td>Pivot Chart Report</td>
<td>Returns number of underlying values; null values excluded.</td>
<td></td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>Query</td>
<td>Returns standard deviation of values.</td>
<td>STDDEV(column definition)</td>
</tr>
<tr>
<td>Variance</td>
<td>Query</td>
<td>Calculates the variance of the selected measure evaluated over the specified dataset.</td>
<td>VARIANCE(column definition)</td>
</tr>
<tr>
<td>Weight</td>
<td>Query</td>
<td>Used to compute weighted values in Pivot reports.</td>
<td>WEIGHT(column definition)</td>
</tr>
<tr>
<td>Rank</td>
<td>Pivot</td>
<td>Returns the rank of a number in a column of numbers.</td>
<td>RANK (numbers, break_col)</td>
</tr>
<tr>
<td>Function</td>
<td>Section Used in:</td>
<td>Operation</td>
<td>SQL Function Generated</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>% of Column</td>
<td>Pivot</td>
<td>Returns sum of all underlying values as a percentage of their respective surface column.</td>
<td></td>
</tr>
<tr>
<td>% of Row</td>
<td>Pivot</td>
<td>Returns sum of underlying values as a percentage of their respective surface row.</td>
<td></td>
</tr>
<tr>
<td>% of Grand</td>
<td>Pivot, Chart</td>
<td>Returns sum of underlying values as a percentage of all surface values in the report.</td>
<td></td>
</tr>
<tr>
<td>Increase</td>
<td>Pivot</td>
<td>Calculates the increase between the previous two rows or columns.</td>
<td></td>
</tr>
<tr>
<td>% Increase</td>
<td>Pivot</td>
<td>Calculates the percentage increase between the previous two rows or columns.</td>
<td></td>
</tr>
<tr>
<td>Title</td>
<td>Report</td>
<td>Returns column names.</td>
<td></td>
</tr>
</tbody>
</table>
## Data Types

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic</td>
<td>BrioQuery will automatically determine the data type returned from the database. This is the default and should be the normal choice.</td>
</tr>
<tr>
<td>Byte</td>
<td>A single byte of computer storage. Bytes can take numeric values from 0 to 255 and can also be used to store a single text character.</td>
</tr>
<tr>
<td>Date</td>
<td>Calendar date. This will be stored in the format selected, typically mm/dd/yy.</td>
</tr>
<tr>
<td>Integer (16 bit)</td>
<td>A 16-bit value (2 bytes). A 16-bit integer can take values from 0 to 65,536. If the integer is signed, it can take values ranging from +32,768 to -32,768.</td>
</tr>
<tr>
<td>Integer (32 bit)</td>
<td>A 32-bit value (4 bytes). A 32-bit integer can take values from 0 to 16,777,216. If the integer is signed, it can take values ranging from +8,388,608 to -8,388,608.</td>
</tr>
<tr>
<td>Long Text</td>
<td>Very long text fields. Maximum length is defined by the database and connection API.</td>
</tr>
<tr>
<td>Real</td>
<td>Numbers with decimal points. Up to 5 positions are allowed to the right of the decimal. The range of values depends on the number of decimal points.</td>
</tr>
<tr>
<td>String</td>
<td>Text characters. Maximum length is 256 characters.</td>
</tr>
<tr>
<td>Time</td>
<td>Time. The format used for times is set by user preference.</td>
</tr>
<tr>
<td>TimeStamp</td>
<td>Date/time combination. The format used is set by user preference.</td>
</tr>
</tbody>
</table>
World Wide Web URLs

The following URLs offer assistance when using DSS and BrioQuery.

**BrioQuery Tips Page**
http://www.adpc.purdue.edu/WAI/Brio/brio_tips.htm

**DSS Homepage**
http://www.adpc.purdue.edu/WAI/DSS/DSS.htm

**WAI Homepage**
http://www.adpc.purdue.edu/WAI/